OpenVPN.eu
http://forum.openvpn.eu/

Connection established. Or not?
http://forum.openvpn.eu/viewtopic.php?f=44&t=6318
Page 1 of 1

Author:  Mester [ 18.06.2009 17:28 ]
Post subject:  Connection established. Or not?

Hi,

I have an IPcop machine with red + green + orange interfaces. I set up Zerina OpenVPN on the IPcop machine and installed openvpn to the client machine. I downloaded the client package and connected to the IPcop VPN.

The client machine received an IP address from the IPcop, 10.0.10.6. On the IPcop's openvpn tab I can see that the client status is open (green). But if I try to ping a machine on the IPcop's green network from the VPN client machine I have no answer.

The green network on the IPcop is 192.168.1.x
The IP address of the client machine is 192.168.11.101
ipconfig /all on the XP client machine's OpenVPN adapter:
IP address: 10.0.10.6
Netmask: 255.255.255.252
Gateway:
DHCP server: 10.0.10.5


I made some research and installed Zerina on another IPcop machine. And the VPN works fine with that machine. As I see the only diference between the two network is that on this machine IPcop is connected directly to the internet. On the other machine (which I have problem with) is connected to the internet through a CISCO router. What should I set on the router to make VPN work?

Author:  eatvonpete [ 19.06.2009 07:54 ]
Post subject:  Re: Connection established. Or not?

Hello,

you need a route on the cisco Router to route the client traffic to the IP Cop.

Code:
ip route 10.0.10.0 255.255.255.0 192.168.1.x (x= IP of IPCop Green)

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/