It is currently 18.10.2017 02:07


All times are UTC




Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 05.03.2014 18:17 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2185
Crashdemon wrote:
Kann es vllt. sein, dass der sich mit dem DHCP-Lease der WLAN-Karte in gehege kommt. Da der Tunnel ja über WLAN läuft und die Adresse alle 10min neu gehölt wird?


warum das denn ???

Theoretisch ist das "Wurscht" entsprechnde Parametrisierung vorausgesetzt, baut er eben den Tunnel neu (siehe: wie funktioniert openVPN)
aber können muss er das dazu :)

F.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 06.03.2014 08:22 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Also meinste das Problem liegt darin, dass der DNS Server nicht mehr erreichbar ist wenn die Verbindung abbricht? Und deshalb kein Reconnect erfolgen kann, weil er den Hostnamen nicht auflösen kann?

Mit meinem Smart hat es übrigens 2std ohne Probleme funktioniert.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 06.03.2014 11:48 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Also ich hab den Hostname mal durch eine feste IP ersetzt und das Problem besteht weiterhin.

Code:
ERROR: No Route to Host!
See log for detailsThu Mar 06 12:44:33 2014 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 06.03.2014 15:12 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Ich hab auch mal einen Secondary DNS hinzugefügt der auch erreichbar ist wenn der Tunnel nicht mehr besteht. Aber dann hat er Probleme die Verbindung wieder aufzubauen:

Code:
Thu Mar 06 16:07:54 2014 [server] Inactivity timeout (--ping-restart), restarting
Thu Mar 06 16:07:54 2014 TCP/UDP: Closing socket
Thu Mar 06 16:07:54 2014 SIGUSR1[soft,ping-restart] received, process restarting
Thu Mar 06 16:07:54 2014 Restart pause, 2 second(s)
Thu Mar 06 16:07:56 2014 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Thu Mar 06 16:07:56 2014 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Mar 06 16:07:56 2014 Re-using SSL/TLS context
Thu Mar 06 16:07:56 2014 LZO compression initialized
Thu Mar 06 16:07:56 2014 WARNING: using --fragment and --mtu-test together may produce an inaccurate MTU test result
Thu Mar 06 16:07:56 2014 Control Channel MTU parms [ L:1562 D:166 EF:66 EB:0 ET:0 EL:0 ]
Thu Mar 06 16:07:56 2014 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Mar 06 16:07:56 2014 Data Channel MTU parms [ L:1562 D:1300 EF:62 EB:135 ET:0 EL:0 AF:3/1 ]
Thu Mar 06 16:07:56 2014 Fragmentation MTU parms [ L:1562 D:1300 EF:61 EB:135 ET:1 EL:0 AF:3/1 ]
Thu Mar 06 16:07:56 2014 Local Options hash (VER=V4): 'e05aa1c5'
Thu Mar 06 16:07:56 2014 Expected Remote Options hash (VER=V4): '0088baee'
Thu Mar 06 16:07:56 2014 UDPv4 link local: [undef]
Thu Mar 06 16:07:56 2014 UDPv4 link remote: 188.105.78.51:1194
ERROR: TLS error! See log for detailsThu Mar 06 16:08:56 2014 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Mar 06 16:08:56 2014 TLS Error: TLS handshake failed
Thu Mar 06 16:08:56 2014 TCP/UDP: Closing socket
Thu Mar 06 16:08:56 2014 SIGUSR1[soft,tls-error] received, process restarting
Thu Mar 06 16:08:56 2014 Restart pause, 2 second(s)
DisconnectedTimeout[Maybe your cetificates are not valid. Please check if it is revoked], restart pause will be ignored! Shuting down OpenVPN ...


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 07.03.2014 08:09 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2185
Crashdemon wrote:
Also ich hab den Hostname mal durch eine feste IP ersetzt und das Problem besteht weiterhin.

Code:
ERROR: No Route to Host!
See log for detailsThu Mar 06 12:44:33 2014 write UDPv4: No Route to Host (WSAEHOSTUNREACH) (code=10065)

..hmm und warum NO route ?
was sagen an der Stelle die Routingtabellen ?

F.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 07.03.2014 10:40 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Crashdemon wrote:
..hmm und warum NO route ?
was sagen an der Stelle die Routingtabellen ?


Die Routingtabelle ist die gleiche wie auch schon oben gepostet, hier aber nochmal die ganze:

Code:
Aktive Routen:
     Netzwerkziel    Netzwerkmaske          Gateway   Schnittstelle  Anzahl
          0.0.0.0          0.0.0.0  129.217.127.254  129.217.124.192      25
          0.0.0.0        128.0.0.0       172.16.0.5      172.16.0.6       1
         25.0.0.0        255.0.0.0    25.141.41.231   25.141.41.231       20
    25.141.41.231  255.255.255.255        127.0.0.1       127.0.0.1       20
   25.255.255.255  255.255.255.255    25.141.41.231   25.141.41.231       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
        128.0.0.0        128.0.0.0       172.16.0.5      172.16.0.6       1
     129.217.64.0    255.255.192.0  129.217.124.192  129.217.124.192      25
  129.217.124.192  255.255.255.255        127.0.0.1       127.0.0.1       25
  129.217.255.255  255.255.255.255  129.217.124.192  129.217.124.192      25
       172.16.0.0    255.255.255.0       172.16.0.5      172.16.0.6       1
       172.16.0.4  255.255.255.252       172.16.0.6      172.16.0.6       30
       172.16.0.6  255.255.255.255        127.0.0.1       127.0.0.1       30
   172.16.255.255  255.255.255.255       172.16.0.6      172.16.0.6       30
      178.4.87.57  255.255.255.255  129.217.127.254  129.217.124.192      1
        224.0.0.0        240.0.0.0    25.141.41.231   25.141.41.231       20
        224.0.0.0        240.0.0.0  129.217.124.192  129.217.124.192      25
        224.0.0.0        240.0.0.0       172.16.0.6      172.16.0.6       30
  255.255.255.255  255.255.255.255    25.141.41.231   25.141.41.231       1
  255.255.255.255  255.255.255.255  129.217.124.192  129.217.124.192      1
  255.255.255.255  255.255.255.255       172.16.0.6               3       1
  255.255.255.255  255.255.255.255       172.16.0.6           10007       1
  255.255.255.255  255.255.255.255       172.16.0.6      172.16.0.6       1
Standardgateway:        172.16.0.5


Bzw. der für OpenVPN relevante teil:

Code:
Aktive Routen:
     Netzwerkziel    Netzwerkmaske          Gateway   Schnittstelle  Anzahl
       172.16.0.0    255.255.255.0       172.16.0.5      172.16.0.6       1
       172.16.0.4  255.255.255.252       172.16.0.6      172.16.0.6       30
       172.16.0.6  255.255.255.255        127.0.0.1       127.0.0.1       30
   172.16.255.255  255.255.255.255       172.16.0.6      172.16.0.6       30
Standardgateway:        172.16.0.5


Gut keine Route wird darin liegen, dass der ja Standardmäßig meinen gesamten Internetverkehr über den Tunnel schickt, also an den Standardgateway 172.16.0.5 den OpenVPN ja virtuell erzeugt. Da der den nicht mehr erreichen kann wenn die Verbindung abgebrochen ist, kommt warscheinlich die Fehlermeldung "no route to host".

Aber es kommen immer mal wieder andere Fehlermeldungen, gerade habe ich z.B.

Code:
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [1]
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [2]
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [3]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [5]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [8]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [9]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [10]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [11]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [12]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [13]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [17]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [19]


bei mir stehen, die Verbindung läuft aber seid 38 min stabil.

Komisch ist ja auch, dass es auf meinem Android Smartphone ohne Probleme klappt über das selbe WLAN, selbst wenn ich kurz aus dem WLAN bin stellt er die Verbindung direkt wieder her sobald ich wieder drin bin.

Gibt es vllt. irgendwelche "Known Bugs" die unter WinXP SP3 bekannt sind?

Was auch noch eine Vermutung von mir wäre, das er für das WLAN keine neue DHCP Adresse beziehen kann, weil er das über den Tunnel versucht?

Ereignismeldung am WinXP Client:

Code:
Der Computer konnte die Netzwerkadresse, die durch den DHCP-Server für die Netzwerkkarte mit der Netzwerkadresse 00215D7EC6EE (<-- WLAN Adapter) zugeteilt wurde, nicht erneuern. Der folgende Fehler ist aufgetreten:
Das Zeitlimit für die Semaphore wurde erreicht. . Es wird weiterhin im Hintergrund versucht, eine Adresse vom Netzwerkadressserver (DHCP) zu erhalten.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 07.03.2014 13:34 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2185
Crashdemon wrote:

die openVPN Routen sind erst mal irrelevant... wichtig ist alles, was den Tunnel aufbaut und am Leben erhält !
Also das was korrekt auch da sein muss, wenn kein Tunnel etabliert ist.
Dieser Teil darf auch nicht umgeleitet/überschrieben werden -> zumindest nicht so, dass die Funktion weg ist :)

Quote:
Gut keine Route wird darin liegen, dass der ja Standardmäßig meinen gesamten Internetverkehr über den Tunnel schickt, also an den Standardgateway 172.16.0.5 den OpenVPN ja virtuell erzeugt. Da der den nicht mehr erreichen kann wenn die Verbindung abgebrochen ist, kommt warscheinlich die Fehlermeldung "no route to host".

Aber es kommen immer mal wieder andere Fehlermeldungen, gerade habe ich z.B.

Code:
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [1]
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [2]
Fri Mar 07 11:16:57 2014 Replay-window backtrack occurred [3]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [5]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [8]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [9]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [10]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [11]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [12]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [13]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [17]
Fri Mar 07 11:23:57 2014 Replay-window backtrack occurred [19]


habe ich SO noch nicht gesehen, aber im Zusammenhang mit unbekannten Clients, die das Namesystem nicht auflösen kann kommen auch backtrack messages
Quote:
bei mir stehen, die Verbindung läuft aber seid 38 min stabil.

Komisch ist ja auch, dass es auf meinem Android Smartphone ohne Probleme klappt über das selbe WLAN, selbst wenn ich kurz aus dem WLAN bin stellt er die Verbindung direkt wieder her sobald ich wieder drin bin.

Gibt es vllt. irgendwelche "Known Bugs" die unter WinXP SP3 bekannt sind?
ja .. eigentlich nur die bekannten Bus beim setzzen der Routen :)
Quote:
Was auch noch eine Vermutung von mir wäre, das er für das WLAN keine neue DHCP Adresse beziehen kann, weil er das über den Tunnel versucht?

Ereignismeldung am WinXP Client:

Code:
Der Computer konnte die Netzwerkadresse, die durch den DHCP-Server für die Netzwerkkarte mit der Netzwerkadresse 00215D7EC6EE (<-- WLAN Adapter) zugeteilt wurde, nicht erneuern. Der folgende Fehler ist aufgetreten:
Das Zeitlimit für die Semaphore wurde erreicht. . Es wird weiterhin im Hintergrund versucht, eine Adresse vom Netzwerkadressserver (DHCP) zu erhalten.

Glaube ich nicht... dann müsste der Wlan-Adapter weg vom Wlan auf den Tunnel umgebogen worden sein - wer macht denn so was ??
Kann aber ein Wlan-Stack Problem sein... wieder eine Sache, die mir nicht begegnet ist :)
Bisher waren Win-XP + Win7 Clients nie das Problem... gab bei frühen openVPN-Clöients mal Konfigurationsbedarf ( mAN-PAGES lesen) aber sonst egal ob Kabel oder WLAN..

F.
ps: wie gesagt: routen dann klären, wenn er nicht lann !


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 09.03.2014 12:24 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Crashdemon wrote:
ps: wie gesagt: routen dann klären, wenn er nicht lann !


Versteh ich nicht?


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 09.03.2014 14:26 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2185
Crashdemon wrote:
Crashdemon wrote:
ps: wie gesagt: routen dann klären, wenn er nicht Kann !


Versteh ich nicht?

nich lann sondern KANN (Tippfehler) ..
wenn du nichts verstehst hast du auch kein Problem :-)
[Leistung einkaufen und gut...]
F.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 11.03.2014 09:18 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Ich hab mir mal das Problem mit den Routen angesehen. Dazu habe ich folgenden Link gefunden: http://community.openvpn.net/openvpn/wiki/RoutedLans

Sobald ich allerdings route 129.217.64.0 255.255.192.0 zu meiner Server Config hinzufüge. Ist der Server aus den Netz überhaupt nicht mehr erreichbar?

Außerdem scheint der Client auch manchmal von seiner IPv6 Adresse zu senden.
MULTI: bad source address from client [fe80::2ff:ccff:fe03:ffd5], packet dropped

Wie kann man das verhindern oder beheben?


Top
Offline Profile  
Reply with quote  
 Post subject: Re: OpenVPN suddenly drops connection!
PostPosted: 11.03.2014 09:54 
Tripple-DES
Tripple-DES

Joined: 24.02.2014 11:52
Posts: 18
Vllt. hat ja jemand eine minimale Server und Client Config zu Hand die ich testen kann.


Top
Offline Profile  
Reply with quote  
 Post subject: OpenVPN suddenly drops connection
PostPosted: 05.03.2016 08:19 
DES
DES
User avatar

Joined: 04.03.2016 13:19
Posts: 2
Location: Israel
Downgrade to 9505 version solve this problem.

Can you tell me how to connect OpenVPN clients with small configuration build in new version?


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 27 posts ]  Moderator: Moderators Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net