It is currently 22.03.2018 00:08

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: HTTP breaks OpenVPN Tunnel
PostPosted: 31.10.2011 07:24 

Joined: 31.10.2011 07:11
Posts: 1

I have OpenVPN configuration with following setup files. It's working without problems when I use UDP protocol. But I need TCP on 443 port to pass through proxy somewhere. When I use it, VPN creates tunnel, I can ping servers, but when I try to access some HTTP server (in our subnet behind VPN server), page starts to load, sometimes part of page is displayed, but after moment, data stops loading and VPN is not working, I can't ping anything over VPN. When I reconnect VPN, situation is repeating. As I wrote, with UDP there is no problem. Any idea?

Server configuration:
mode server
proto tcp-server
port 443
dev tap0
push "route"
ca ca.crt
cert VPN-Server.crt
key VPN-Server.key
dh dh1024.pem
plugin /usr/lib/openvpn/ login
keepalive 10 120
log /var/log/vpn.log
verb 9

Client configuration:
remote <server name>
proto tcp-client
port 443
dev tap
ca ca.crt
cert VPN-Client.crt
key VPN-Client.key
verb 9
mute 10


Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ]  Moderator: Moderators

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created