It is currently 27.05.2017 21:20


All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Routing-Probleme
PostPosted: 17.01.2016 18:52 
DES
DES

Joined: 17.01.2016 18:34
Posts: 3
Hallo,

ich bin absoluter Neuling im Bereich OpenVPN.
Ich habe auf einem Server 2008R2 den VPN-Server installiert.
Wenn ich mich mit einem Softwareklient zum VPN-Server verbinde, kann ich die 10.8.0.1 ( IP des OpenVPN ) anpingen.
Nun habe ich aber folgende Konstellation:

Client ( 192.168.0.2/30 ) -> VPN-Router ( 192.168.0.1/30 ) -> Internet -> OpenVPN-Server ( externe IP + 10.8.0.1 )

Client-GW: 192.168.0.1
Server-GW: normales Standard-GW + statische Route 192.168.0.0/16 -> 10.8.0.2

Der VPN-Router baut eine VPN-Verbindung auf und trägt auch das korrekte Routing bei sich ein.
Allerdings sehe ich auf der Serverseite keine entsprechenden Routineeinträge im LOG für das 192.168.0.0/30 er Netz.

Ein Ping vom Server zur 192.168.0.2 sowie ein Ping vom Client zur 10.8.0.1 gehen nicht :-(

Kann mir jemand helfen ?

Hier noch die Serverkonfig:

port 1194
proto udp
dev tun
ca "C:\\Program Files (x86)\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files (x86)\\OpenVPN\\config\\server.crt"
key "C:\\Program Files (x86)\\OpenVPN\\config\\server.key" # This file should be kept secret
crl-verify "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\crl.pem"
dh "C:\\Program Files (x86)\\OpenVPN\\config\\dh1024.pem"
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3


Last edited by Carsten_R on 18.01.2016 13:13, edited 1 time in total.

Top
Offline Profile  
Reply with quote  
 Post subject: Re: Routing-Probleme
PostPosted: 18.01.2016 08:04 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2183
Carsten_R wrote:
Hallo,

ich bin absoluter Neuling im Bereich OpenVPN.
Ich habe auf einem Server 2008R2 den VPN-Server installiert.
Wenn ich mich mit einem Softwareklient zum VPN-Server verbinde, kann ich die 10.8.0.1 ( IP des OpenVPN ) anpingen.
Nun habe ich aber folgende Konstellation:

Client ( 192.168.0.2/30 ) -> VPN-Router ( 192.168.0.1/30 ) -> Internet -> OpenVPN-Server ( externe IP + 10.8.0.1 )

Client-GW: 192.168.0.1
Server-GW: normales Standard-GW + statische Route 192.168.0.0/16 -> 10.8.0.2

Der VPN-Router baut eine VPN-Verbindung auf und trägt auch das korrekte Routing bei sich ein.
Allerdings sehe ich auf der Serverseite keine entsprechenden Routineeinträge im LOG für das 192.168.0.0/30 er Netz.

Ein Ping vom Server zur 192.168.0.2 sowie ein Ping vom Client zur 10.8.0.1 gehen nicht :-(

Kann mir jemand helfen ?


Hallo,
nur Neuling bei openVPN (und genau das tut)
Der Rest ist Routing (und das hat absolut nichts mit oprnVPN zu tun).
Ich wüsste auch nicht, was ein VPN-Router ist - genauerweise, ich kenne etliche VPN-Router, aber die tun alle net-2-net mittels IPSec .

F.
ps: was meinst du wozu
1. die Code Funktion im Forum da ist ?
2. wer soll sich dir Mühe machen, aus 100 Zeilen Kommentar( = nutzloser Text) die 3..5 relevanten Zeile rauszufinden?
3. es sind gefühlte 100 Antworten zu deinem Problem hier im Forum vorhanden => FAQ


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Routing-Probleme
PostPosted: 18.01.2016 13:16 
DES
DES

Joined: 17.01.2016 18:34
Posts: 3
hallo dl5ym,

ich habe die konfig von dem Müll befreit.
Deine Antwort das gefühlte 100 Beiträge zu meinem Problem da sind hilft mir leider nicht weiter.
Hast du einen Beitrag für mich ?

Gruß, Carsten


dl5ym wrote:
Carsten_R wrote:
Hallo,

ich bin absoluter Neuling im Bereich OpenVPN.
Ich habe auf einem Server 2008R2 den VPN-Server installiert.
Wenn ich mich mit einem Softwareklient zum VPN-Server verbinde, kann ich die 10.8.0.1 ( IP des OpenVPN ) anpingen.
Nun habe ich aber folgende Konstellation:

Client ( 192.168.0.2/30 ) -> VPN-Router ( 192.168.0.1/30 ) -> Internet -> OpenVPN-Server ( externe IP + 10.8.0.1 )

Client-GW: 192.168.0.1
Server-GW: normales Standard-GW + statische Route 192.168.0.0/16 -> 10.8.0.2

Der VPN-Router baut eine VPN-Verbindung auf und trägt auch das korrekte Routing bei sich ein.
Allerdings sehe ich auf der Serverseite keine entsprechenden Routineeinträge im LOG für das 192.168.0.0/30 er Netz.

Ein Ping vom Server zur 192.168.0.2 sowie ein Ping vom Client zur 10.8.0.1 gehen nicht :-(

Kann mir jemand helfen ?


Hallo,
nur Neuling bei openVPN (und genau das tut)
Der Rest ist Routing (und das hat absolut nichts mit oprnVPN zu tun).
Ich wüsste auch nicht, was ein VPN-Router ist - genauerweise, ich kenne etliche VPN-Router, aber die tun alle net-2-net mittels IPSec .

F.
ps: was meinst du wozu
1. die Code Funktion im Forum da ist ?
2. wer soll sich dir Mühe machen, aus 100 Zeilen Kommentar( = nutzloser Text) die 3..5 relevanten Zeile rauszufinden?
3. es sind gefühlte 100 Antworten zu deinem Problem hier im Forum vorhanden => FAQ


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Routing-Probleme
PostPosted: 18.01.2016 14:03 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2183
Hallo,
was macht dein VPN-Router und was für VPN Läuft da drauf ?


Aufagabe danach: durch welche Interfaces müssen die Pakete, dass es nach dem von dir entworfenen Plan auch funktionieren kann - ?

F.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Routing-Probleme
PostPosted: 18.01.2016 14:16 
DES
DES

Joined: 17.01.2016 18:34
Posts: 3
Der Router baut eine Internetverbindung und danach die VPN-Veribindung auf.
Auf dem Router läuft für die VPN-Verbindung ein OpenVPN Client.

Ablauf Paket vom Client aus:

Client (192.168.0.2/30) -> Router LAN (192.168.0.1/30) - Router WAN(1.2.3.4) mit OpenVPN zum Server -> Internet -> Windows-Server WAN ETH0 -> Windows OpenVPN ETH1 (10.8.0.1)


Hier noch ein Auszug aus dem LOG:

Mon Jan 18 14:11:46 2016 VPN-01/1.2.3.4:35070 Bad LZO decompression header byte: 42
Mon Jan 18 14:11:54 2016 VPN-01/1.2.3.4:35070 [VPN-01] Inactivity timeout (--ping-restart), restarting
Mon Jan 18 14:11:54 2016 VPN-01/1.2.3.4:35070 SIGUSR1[soft,ping-restart] received, client-instance restarting
Mon Jan 18 14:13:49 2016 MULTI: multi_create_instance called
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 Re-using SSL/TLS context
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 LZO compression initialized
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 Local Options hash (VER=V4): '530fdded'
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 Expected Remote Options hash (VER=V4): '41690919'
Mon Jan 18 14:13:49 2016 1.2.3.4:42872 TLS: Initial packet from 1.2.3.4:42872, sid=61239666 80b82346
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 CRL CHECK OK: /C=DE/ST=NA/L=Stadt/O=externe-domain/OU ... domain.com
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 VERIFY OK: depth=1, /C=DE/ST=NA/L=Stadt/O=externe-domain/OU ... domain.com
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 CRL CHECK OK: /C=DE/ST=NA/O=externe-domain/OU=IT/CN=V ... domain.com
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 VERIFY OK: depth=0, /C=DE/ST=NA/O=externe-domain/OU=IT/CN=V ... domain.com
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1541'
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Mon Jan 18 14:13:50 2016 1.2.3.4:42872 [VPN-01] Peer Connection Initiated with 1.2.3.4:42872
Mon Jan 18 14:13:50 2016 VPN-01/1.2.3.4:42872 MULTI: Learn: 10.8.0.14 -> VPN-01/1.2.3.4:42872
Mon Jan 18 14:13:50 2016 VPN-01/1.2.3.4:42872 MULTI: primary virtual IP for VPN-01/1.2.3.4:42872: 10.8.0.14
Mon Jan 18 14:13:52 2016 VPN-01/1.2.3.4:42872 PUSH: Received control message: 'PUSH_REQUEST'
Mon Jan 18 14:13:52 2016 VPN-01/1.2.3.4:42872 SENT CONTROL [VPN-01]: 'PUSH_REPLY,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.14 10.8.0.13' (status=1)
Mon Jan 18 14:14:03 2016 VPN-01/1.2.3.4:42872 Bad LZO decompression header byte: 42
Mon Jan 18 14:14:13 2016 VPN-01/1.2.3.4:42872 Bad LZO decompression header byte: 42


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Routing-Probleme
PostPosted: 18.01.2016 16:21 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2183
Hallo
1. das mit dem Code Tag immer noch nicht begriffen ?!
2. im Topic steht Routing Probeleme , im Beitrag tust du so als ob es ein Tunneproblem ist
was nun ??

Du solltest z.B. wenn du http://www.qsi.de/index.php?title=Implementierung verwendest wieder zu SE1 zurückkehren und überprüfen.

Nach dem Genannten Modell irgendwo zwischen SE1 und SE6 Murks gemacht.
Na ja .. es sei denn du willst in Berlin einen Flughafen bauen ;-)


ansonsten wenn deine Bescghreibung stimmen sollte, dann hast du im ersten Beitrag (Zeile5) M
Quote:
Client ( 192.168.0.2/30 ) -> VPN-Router ( 192.168.0.1/30 ) -> Internet -> OpenVPN-Server ( externe IP + 10.8.0.1 )
urks geschrieben.

Wundern tut mich auch, dass man neuerdings einen Windows-Server über ein Modem direkt ans Internet hängt. (scheinbar hast du SDSL), aber na ja...

F.

ps: es gibt auch etliche andere Projektmiodelle mit anderen Termini, du darfst auch ein anderes (Projekt)Modell verwenden. Papier/Grafiken usw. braucht man immer erst, wenn man es anderen erklären muss.


Top
Offline Profile  
Reply with quote  
 Post subject: Routing Probleme
PostPosted: 28.04.2016 13:54 
DES
DES

Joined: 27.04.2016 14:04
Posts: 5
Location: Ireland
Wie ist denn das Routing eingestellt:

- krzeste Route
- kologische
- schnellste

das knnte auch mitspielen

_________________
bestroulettegame.com


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ]  Moderator: Moderators

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net