It is currently 19.11.2017 13:49


All times are UTC




Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Authenticate/Decrypt packet error: bad packet ID
PostPosted: 11.03.2015 08:14 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2188
Hille wrote:

Allerdings bekomme ich auch bei MTU 1300 die oben genannte Fehlermeldung nach einiger Zeit. Irgendwie bekomme ich das nicht so recht in den Griff. Gibt es noch andere Möglichkeiten?

weg von UDP und mit TCP schauen... sollte deutlich weniger werden.

Ausserdem:
Warnings kann man (sehr oft) ignorieren, wenn man weiss, dass sie keinen Schaden machen.
Decrypt-Errors sind auch - erst mal- bedeutungslos, der Kram wird (deswegen) sowieso wiederholt, bei heftigen Versionen (bis Abbruch) ist es auch interessant, ob es deine Tunnelparameter sind oder ob ein "Angriff" läuft. UDP als ungerichtete Kommunikation ist da immer etwas...na ja.. Ist zwar typisch schneller als TCP, weil ja der "Bestätigungsverkehr" fehlt, aber das kann auch schon mal umschlagen.

F.
ps: stabil heisst nicht fehlerfrei - wozu sonst in aller Welt sind die Fehlerkorrekturmöglichkeiten sonst da ?


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Authenticate/Decrypt packet error: bad packet ID
PostPosted: 12.03.2015 07:52 
DES
DES

Joined: 03.03.2015 16:01
Posts: 9
dl5ym wrote:
weg von UDP und mit TCP schauen... sollte deutlich weniger werden.


Ja, die Fehlermeldungen sind komplett weg. Probleme mit der Performance konnte ich soweit auch keine feststellen. Aber, OpenVPN per IOS funktioniert nun leider nicht mehr. Die Verbindung selber funktioniert problemlos, mehr aber auch nicht. Ein Ping vom Server funktioniert ebenfalls. Nur die Verbindung zu Webseiten eben nicht. Die Windows Client hingegen funktionieren tadellos. Gibt es hier evtl. eine Lösung?


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Authenticate/Decrypt packet error: bad packet ID
PostPosted: 12.03.2015 10:19 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2188
Hille wrote:
dl5ym wrote:
weg von UDP und mit TCP schauen... sollte deutlich weniger werden.


Ja, die Fehlermeldungen sind komplett weg. Probleme mit der Performance konnte ich soweit auch keine feststellen. Aber, OpenVPN per IOS funktioniert nun leider nicht mehr. Die Verbindung selber funktioniert problemlos, mehr aber auch nicht. Ein Ping vom Server funktioniert ebenfalls. Nur die Verbindung zu Webseiten eben nicht. Die Windows Client hingegen funktionieren tadellos. Gibt es hier evtl. eine Lösung?


du hast beim iOS auch die Config geändert ? UDP -> TCP ?

der Rest sollte davon unbeeindruckt sein (du stellst ja nur den Tunnel als solchen um).

F.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Authenticate/Decrypt packet error: bad packet ID
PostPosted: 12.03.2015 10:31 
DES
DES

Joined: 03.03.2015 16:01
Posts: 9
dl5ym wrote:
du hast beim iOS auch die Config geändert ? UDP -> TCP ?


Ja, habe ich.

Ich Dussel habe doch auf dem OpenVPN Server in der Firewall nur nach udp geschaut und geändert.

Code:
iptables -A INPUT -p tcp -i tun0 -s 10.8.0.0/24 --dport 53 -j ACCEPT


So konnte natürlich keine Namesauflösung stattfinden. Die Windows Cliets haben einen anderen DNS-Server genutzt, daher gab es dort keine Probleme. Nun funktioniert es wieder. Danke für die Hilfe.


Top
Offline Profile  
Reply with quote  
 Post subject: Re: Authenticate/Decrypt packet error: bad packet ID
PostPosted: 12.03.2015 12:44 
Profi
Profi

Joined: 23.10.2007 12:10
Posts: 2188
Hille wrote:
Code:
iptables -A INPUT -p tcp -i tun0 -s 10.8.0.0/24 --dport 53 -j ACCEPT


So konnte natürlich keine Namesauflösung stattfinden. Die Windows Cliets haben einen anderen DNS-Server genutzt, daher gab es dort keine Probleme. Nun funktioniert es wieder. Danke für die Hilfe.

Hat aber alles oben nichts wirklich mit Namensauflösung zu tun :)

port 53 nicht rauszulassen (oder den ntp-port / 123 ?) ist etwas sehr...na ja...
Oder nur für extrem M$-lastige Leute :) ... wir schalten alles ein und blocken dann ...

In der U*X-Welt haben wir gelernt: Es wird nur eingeschaltet, was wirklich gebraucht wird.
Theoretisch brauchts da keine Firewall :) Das was du brauchst ist eh auch in jeder Firewall offen, der Rest läuft nicht!
Praktisch brauchts die Firewall (manchmal) um zwischen innen und aussen unterscheiden zu können.
Vielleicht achte ich da mehr auf solche (Namenausflösungs)mechanismen/Dienste usw.

F.

ps: logisch ist TCP langsamer .. du hast den ganzen TCP-Quittungskram/Wiederholungskram zusätzlich... 10...20% könnte das schon mal sein schon sichtbar ob 1000kBits oder 890 kBits :)


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Moderator: Moderators Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net