It is currently 22.11.2017 03:30


All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Config Frage zu den Endpoints unter Windows
PostPosted: 25.11.2013 17:13 
DES
DES

Joined: 30.09.2013 10:24
Posts: 6
Hallo zusammen,

hatte letztens mein Heimnetzwerk ein wenig umgebaut und auch OpenVPN auf einem anderen Linux-Server installiert (vorher auf FritzBox über Freetz-FW).

Soweit scheint das ganze gut zu funktionieren, mit meinem Android komme ich ohne Probleme in mein Netz und von da aus auch wieder raus.
Nur mit Windows tue ich mich da noch etwas schwer.

Folgende Configs sind eingestellt:

server.conf
Code:
port 1194
proto udp
dev tun
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key  # This file should be kept secret
dh /etc/openvpn/dh1024.pem

server 10.0.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "route 192.168.99.0 255.255.255.0"

client-config-dir clients_config
route 10.0.0.0 255.255.255.0
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 192.168.99.1"
client-to-client
keepalive 10 120
tls-auth static.key 0 # This file is secret

cipher AES-128-CBC   # AES
comp-lzo
max-clients 5
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
;log         openvpn.log
;log-append  openvpn.log
verb 4
;mute 20


Config von einem Windows-Client per ccd
Code:
ifconfig-push 10.0.0.6 255.255.255.0


Config auf dem Windows-Client
Code:
remote adresse.adresse
proto udp
dev tun
pull
tls-client
tls-auth static.key 1
ca home-ca.crt
cert home.crt
key home.key
ns-cert-type server
cipher AES-128-CBC
verb 3
mute 50
mssfix
tun-mtu 1500
comp-lzo


Wenn ich mich jetzt mit meinem Windows-Client verbinde, bekomme ich folgende Fehler in meinen Logs:

Code:
Mon Nov 25 18:01:44 2013 There is a problem in your selection of --ifconfig endpoints [local=10.0.0.6, remote=255.255.255.0].  The local and remote VPN endpoints must exist within the same 255.255.255.252 subnet.  This is a limitation of --dev tun when used with the TAP-WIN32 driver.  Try 'openvpn --show-valid-subnets' option for more info.


Was muss ich hierzu in den Subnets einstellen, bzw. welche Option muss geändert werden? Stehe da irgendwie total auf dem Schlauch :-/


Danke vorab und viele Grüße,
Shadow128


Top
Offline Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ]  Moderator: Moderators

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net